Moodle 3.4 gaat minimaal PHP 7 vereisen

Het duurt nog 4 maanden voordat Moodle 3.4 uitkomt, maar nu is bekend dat de nieuwe major release minimaal PHP 7 gaat vereisen. Dat betekent dat je webserver ook deze nieuwste versie moet draaien. Kaart dit tijdig aan bij je Moodle hoster of je eigen IT-afdeling. Sinds medio 2016 biedt Avetica al op een deel van haar Moodle cluster PHP 7 aan en nieuwe Moodle sites draaien al probleemloos op deze nieuwe versie.

Moodle is geschreven in de programmeertaal PHP en sinds Moodle 3.0.1 wordt PHP 7 al ondersteund. De drie belangrijkste voordelen zijn:

  1. Verdubbelde snelheid met PHP 7
  2. PHP 7 gebruikt minder geheugen
  3. Verbeterde foutafhandeling

Die laatste punt is vooral interessant voor Moodle developers. Van meer snelheid en performance wordt iedereen wel blij.

Wil je controleren of jouw Moodle server al klaar is, volg dan de volgende stappen:

  1. Log in als sitebeheerder
  2. Klik in Sitebeheer op Server | Omgeving
  3. Klik op Update Component
  4. Selecteer de Moodle versie in het dropdownmenu
  5. Bekijk of (rode) statussen

Moodle server PHP.png

Ik zag net dat bij updaten component nog niet versie 3.4 getoond werd. Ik hoop dat dit snel beschikbaar komt, zodat je zelf snel kan zien of er nog werk aan de server is.