Terugblik op grote upgrade van Moodle 1.9 naar 2

Een heel grote upgrade van Moodle, zoals die van 1.9 naar 2 zal niet meer plaatsvinden. Op de Moodlemoot in Nieuw Zeeland heeft Martin Dougiamas, oprichter van Moodle, dit laten weten.

Nu zijn er nog steeds organisaties en scholen die Moodle 1.9 gebruiken, terwijl Moodle 2.0 al sinds november 2010 uit is. Het lastige upgrade proces, plugins en maatwerk die niet werken in Moodle 2.x en de ontwikkeling van een nieuwe template, zijn veel gehoorde argumenten om de upgrade uit te stellen. De ondersteuning op Moodle 1.9 is officieel  al gestopt en nieuwe plug-ins worden alleen nog maar ontwikkeld voor Moodle 2, dus veel keuze is er niet. Te lang uitstellen levert overigens nog meer kosten op.

Zelf heb ik al een aantal keren de vraag (angst) gehoord bij maatwerk voor Moodle 2, of deze nutteloos wordt als Moodle 3 uitkomt. Er waren ideeën om deze versie compleet opnieuw te schrijven. Nu staat dit voorlopig nog niet gepland, maar het geeft wel aan wat de impact is van een grote upgrade als klanten zulke vragen gaan stellen.